Oracle Service Bus (OSB) and OEPE Versions on 64-bit Systems

If you are installing Oracle Service Bus (OSB)  – which is the newest version as of this writing – based on WebLogic 10.3.6 you are required to use the Oracle Enterprise Pack for Eclipse (OEPE) (supported with Java 6).

Note that OSB 11g won’t run on WLS 12c. Although WLS 10.3.6 supports JDK 7, at the end I decided to run my WLS installation on the same JDK 6 version used for the OEPE IDE.

Typically matching OSB, WLS and OEPE versions is a no-brainer when downloading the bundle that contains WebLogic with Eclipse and OEPE for a particular 32-bit environment. The real fun starts with systems running 64-bit JVMs.

For my 64-bit CentOS 6.4 system I downloaded all the individual components separately with matching version numbers:

  • Supported Oracle DB 11gR2 (XE works but not officially supported)
  • WebLogic 10.3.6
  • Generic Patch 13573621
  • Eclipse with OEPE
  • OSB Installer
  • RCU (when OSB is used with reporting or OWSM)



You can get all the different OEPE versions from here:

The important thing to understand about the OEPE download is that it contains already ORACLE enterprise funtionality but not the OSB functionality.

Still there exists no separate OSB plugin. When running the OSB installer after the WLS installation, you specify the directory containing Eclipse with OEPE and the functionality will be added.

oui osb

This is the location where you would get an error message telling you that you are using the wrong version of OEPE. If you version matches, OEPE will be updated for OSB functionality.


A good summary for other matching versions of previous product releases can be found in this OTN posting.

Speak Your Mind