What happened with the Web Service Test Client in WebLogic 12.1.2 ?

Trying to run the Web Service Test Client as you used to do it until WebLogic version 12.1.1 fails in WebLogic 12.1.2. It took me a while to find out why.

My 12.1.2 domain was running in development mode, I deployed a web service but could not access the web service test client. The admin console did not display the link under Deployment / Testing and also the typical URL /wls_utc didn’t work.

Web Service Test Client / Console in WebLogic 12.1.2

Now here comes the news.


First of all, the link to access the test client has changed in a way which is hard to spot. No word about this in the release notes. To access the web service test client use the following new URL:


(until 12.1.1 it was wls_utc)


Testing from Console is BROKEN

Of course then you should be able to access the test client using the admin console via Deployments / Testing. Surprisingly this didn’t work for a really simple web service I used for testing. For exactly the same web service, only deployed in 12.1.1 domain, the console displays the testing link.

So not sure if it was only my example, which couldn’t be any simpler, but the testing link was not displayed.


UPDATE: I was trying this with more different web services. I did not work with any of my examples. I looks like a bug to me. I recommend to ask your friendly Oracle consultant if it is a feature.

Using Web Service Test Client from an URL

Although the bug described above, the good news is that you can still use the


for testing, eg.


More Features

Those of you who know the possibilities of the SOA suite test client (part of EM) or the OSB test client might have missed some more features in the WLS web service test client.  The test client coming with 12.1.2 is overhauled (or new?) and comes with a number of additional possibilities like settings for authentication, WS-Adressing, WS-Atomic TX etc. (see the tabs in the first screenshot above).

Let me know if it is working for you.


  1. FangZhen says:

    Thank for the new link of test client, it’s very helpful!

  2. Dmitriy says:

    I have the same issues with Web Logic 12.1.2 : does not work for me either

  3. Thank you, good article.
    I have Weblogic 12.1, and i can access http://localhost:7001/ws_utc. It works fine. My Question is how to integrate ws_utc test application within admin console. Why weblogic doesn’t show test link under environments/testing. any idea how to integrate it?


    • Hi BigO,

      it used to be “integrated”.
      Feel free to file a bug report to Oracle to get it fixed or just type the URL directly.
      I will keep it on my “complains” list and next time I’ll meet an WLS PM I will forward the message!



  4. Gorka Siverio says:

    thx! You are probably the only one on the whole Internet with this explanation!

  5. Guillermo says:

    I recently found an article in Oracle support saying:

    The system can be modified to enable the Web Services Test Client in a Production Mode installation. This solution is for enabling the Web Services Test Client at the WLS Domain level. You can also refer to the document and section in the Cause section:

    (1) From Adminserver console (/console) select the “Lock & Edit” button

    (2) From Fusion Middleware Control 12c (/em) open “WebLogic Domain” and right click on the domain name you want to modify -> Administration -> General Settings -> open the Advanced section -> check “Enable Web Service Test Page” -> Save

    (3) Go back to the AdminServer console and refresh the browser -> the “Activate Changes” button should now be available, select it

    (4) Restart the AdminServer and all managed servers

    (5) The previously mentioned URLs should no longer give a HTTP-404 and should appear as expected

    This is for 12.1.3 Production Installations

  6. suryakant says:

    Thank you so much for this explaination. saved a lot of time and effort. :)

Speak Your Mind