What happened with the Web Service Test Client in WebLogic 12.1.2 ?

Trying to run the Web Service Test Client as you used to do it until WebLogic version 12.1.1 fails in WebLogic 12.1.2. It took me a while to find out why.

My 12.1.2 domain was running in development mode, I deployed a web service but could not access the web service test client. The admin console did not display the link under Deployment / Testing and also the typical URL /wls_utc didn’t work.

Web Service Test Client / Console in WebLogic 12.1.2

Now here comes the news.

New URL

First of all, the link to access the test client has changed in a way which is hard to spot. No word about this in the release notes. To access the web service test client use the following new URL:

http://localhost:7001/ws_utc

(until 12.1.1 it was wls_utc)

tc1

Testing from Console is BROKEN

Of course then you should be able to access the test client using the admin console via Deployments / Testing. Surprisingly this didn’t work for a really simple web service I used for testing. For exactly the same web service, only deployed in 12.1.1 domain, the console displays the testing link.

So not sure if it was only my example, which couldn’t be any simpler, but the testing link was not displayed.

testcl2

UPDATE: I was trying this with more different web services. I did not work with any of my examples. I looks like a bug to me. I recommend to ask your friendly Oracle consultant if it is a feature.

Using Web Service Test Client from an URL

Although the bug described above, the good news is that you can still use the

http://ADMIN_SERVER:PORT/ws_utc/?wsdlURL=XYZ

for testing, eg.

http://localhost:7001/ws_utc/?wsdlUrl=http://localhost:7001/Timing/DelayService?WSDL

More Features

Those of you who know the possibilities of the SOA suite test client (part of EM) or the OSB test client might have missed some more features in the WLS web service test client.  The test client coming with 12.1.2 is overhauled (or new?) and comes with a number of additional possibilities like settings for authentication, WS-Adressing, WS-Atomic TX etc. (see the tabs in the first screenshot above).

Let me know if it is working for you.

Comments

  1. FangZhen says:

    Thank for the new link of test client, it’s very helpful!

  2. Dmitriy says:

    I have the same issues with Web Logic 12.1.2 : does not work for me either

Speak Your Mind

*